1990's mitsubishi cars?

  • Wanna Join? New users you can now register lightning fast using your Facebook or Twitter accounts.
Apr 18, 2005
2,633
29
0
#1
I hear it's common for ^^ cars to make that "tick, tick, tick, tick" sound, mine makes it once I start the engine, and after I let it heat up for a while. When i step on the gas when its not all that heated up, it makes more of a grinding sound along with a tick as i press the gas pedal. usually I just let it heat up and although the ticking doesnt go away completely, it's not nearly as noticeable as when I first start up so it doesnt really interfere with driving itself. I've been told it's the lifters/valves. Just wondering if anyone else has/had familiar problems with their mitsubishi?
 
Jun 5, 2004
21,681
22,507
0
32
#3
WHAT KIND OF CAR IS IT? MY HOMIE HAD A GALANT AND THAT THING HAD SO MANY PROBLEMS WITH IT... SO HE FIXED IT UP, SOLD IT TO ANOTHER HOMIE, AND ITS BEEN RUNNING FINE FOR LIKE 3 YEARS LOL
 

L.D.S.

The Bakersman
Aug 14, 2006
20,176
4,093
0
35
Mizzourah
#4
It is either the lifters or it could be a piston slapping.

Lifters are probably a problem, whereas piston slapping really isn't a big deal.
 

UGT

Sicc OG
Sep 15, 2002
3,341
107
63
35
#5
its common in mitsi's mine does it so does the homies u need ta get sum wd40 on that bitch or sumthin from wat i been told lube it up mine goes away eventually
 
Apr 18, 2005
2,633
29
0
#8
it's a 99 mirage mitsubishi. to get a little more thoroughly in depth about it, i hear (online) it pertains to the lifters which are 2nd generation and the way to 'fix' it is replacing them with 3rd generation lifters due to the size being bigger than the 2nd generation?
 

DuceTheTruth

No Flexxin No Fakin
Apr 1, 2003
6,936
6,017
1
40
#9
In the future I would suggest if you already dont to keep up with your tune-ups and oil changes......because once them spark plugs and wires get super bad THEN they start fukkin up coils and modules and so on.......Thats somethin I almost went thru.
 
May 16, 2002
8,590
11,721
113
46
#13
I hear it's common for ^^ cars to make that "tick, tick, tick, tick" sound, mine makes it once I start the engine, and after I let it heat up for a while. When i step on the gas when its not all that heated up, it makes more of a grinding sound along with a tick as i press the gas pedal. usually I just let it heat up and although the ticking doesnt go away completely, it's not nearly as noticeable as when I first start up so it doesnt really interfere with driving itself. I've been told it's the lifters/valves. Just wondering if anyone else has/had familiar problems with their mitsubishi?

What you want to do is get yourself some sand.





































































:cheeky: